[SOLVED] HTTPS problem with File Previewer Plugin (v5.1.1)

g33kdotnet3959

New Member
YetiShare User
May 14, 2014
4
1
3
Hi,

I use filepreviewer plugin and videos can't be viewable because of "mix content" HTTP and HTTPS

Into source code browser I can see :

<li data-thumb-source="https://mysite.org/plugins/filepreviewer/assets/players/ultimate/content/images/thumbnail.jpg" data-poster-source="" data-video-source="[{source:'http://mysite.org/2a738e8e13ee04ea/myfile.mkv?download_token=11514273ef37eeaba7839c08696860081439f74e775dee62b5da392b18c0f1eb', label:'Original'}]" data-start-at-video="0" data-downloadable="yes"></li>

as you can see the url into "data-video-source="[{source:'" begin with HTTP not with HTTPS

The file used for that is : "_preview_video.html.twig" from "themes/spirit/views/account/partial/"

EDIT : Have another error into console dev browser into the file: "evolution.js" line:240

Uncaught DOMException: Failed to execute 'pushState' on 'History': A history state object with URL 'http://mysite.org/ea5f3122fac2e129/myfile.mp4' cannot be created in a document with origin 'https://mysite.org' and URL 'https://mysite.org/ea5f3122fac2e129?pt=WlRkbVZHc3ZjWGxSVG5VMGIyWlpibTVMVVdSWVFUMDlPaHhjZzJLUk9SRlhUa3d0eGpaaUN5Zz0='.

at updatePageUrlBar (https://mysite.org/themes/spirit/assets/js/evolution.js:240:20)
at successCallback (https://mysite.org/themes/spirit/assets/js/evolution.js:264:9)
at Object.<anonymous> (https://mysite.org/themes/spirit/assets/js/evolution.js:230:13)
at j (https://mysite.org/themes/spirit/assets/js/jquery-1.11.0.min.js:2:27136)
at Object.fireWith [as resolveWith] (https://mysite.org/themes/spirit/assets/js/jquery-1.11.0.min.js:2:27949)
at x (https://mysite.org/themes/spirit/assets/js/jquery-1.11.0.min.js:4:22244)
at XMLHttpRequest.b (https://mysite.org/themes/spirit/assets/js/jquery-1.11.0.min.js:4:26298)

Can you fix it please?
Regards
 
Last edited:

g33kdotnet3959

New Member
YetiShare User
May 14, 2014
4
1
3
Also, when upload finished it give http:// link not https://

My config.php is, of course, https configurated



Here is an example :

When I hit "Download" button it does nothing : Console browser say : "Mixed Content: The site at '<URL>' was loaded over a secure connection, but the file at '<URL>' was redirected through an insecure connection. This file should be served over HTTPS. This download has been blocked. See <URL> for more details."

 
Last edited:

cr33p

Member
YetiShare User
May 8, 2016
33
2
8
you should use https on both servers, main server and file server
mixed content doesn't showing on modern browsers
 

adam

Administrator
Staff member
Dec 5, 2009
2,008
97
48
Via the database, go to the 'file_server' table. Look in the 'serverConfig' column for your server entry and ensure the following setting is https.

674
 
  • Like
Reactions: cr33p