index not found

adam

Administrator
Staff member
Dec 5, 2009
1,972
84
48
Hi,

I believe this was resolved via the ticketing system. For other peoples benefit, the fix was to purge the application cache via the admin area.

Thanks,
Adam.
 

Rionerotnt

New Member
Feb 22, 2021
4
0
1
index.php

<?php

/**
* Entry point. All requests are forwarded via .htaccess/mod_rewrite
*
* i.e. index.php?url=http://urlsample.com/controller/action/
*
* @author MFScripts.com - [email protected]
*/
// get requesting url
$url = (isset($_GET['_page_url']) && (strlen($_GET['_page_url']))) ? $_GET['_page_url'] : 'index';
$url = str_replace(array('../'), '', $url);
define('_INT_PAGE_URL', $url);

// include framework
use App\Core\Framework;
require_once('app/core/Framework.class.php');

// setup environment and process route
Framework::run();


.htaccess

# for testing
order allow,deny
allow from all

# override max php upload settings. Might not work on all servers
#php_value upload_max_filesize 4000M
#php_value post_max_size 4000M

# setup xsendfile if the module is enabled
<IfModule mod_xsendfile.c>
<Files *.php>
XSendFile On
SetEnv MOD_X_SENDFILE_ENABLED 1
</Files>
</IfModule>

# disable mod security for admin area
<IfModule mod_security.c>
<If "%{REQUEST_URI} =~ m#/admin/#">
SecFilterEngine Off
SecFilterScanPOST Off
</If>
</IfModule>

# disable mod security
#<IfModule mod_security.c>
# SecFilterEngine Off
# SecFilterScanPOST Off
#</IfModule>

# redirect www to non-www
#RewriteCond %{HTTP_HOST} ^www\.(.*)$ [NC]
#RewriteRule ^(.*)$ http://%1/$1 [R=301,L]

RewriteEngine On

# force https
#RewriteCond %{HTTPS} !=on
#RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

#RewriteRule . - [E=no-gzip:1]
RewriteBase /ucloud/

# forward to install if it exists
#RewriteCond %{DOCUMENT_ROOT}/install -d
#RewriteCond %{REQUEST_URI} !(install) [NC]
#RewriteRule ^(.*) /install/ [L,redirect=302]

# forward app requests
#RewriteCond %{HTTP:Authorization} ^(.+)$
#RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#RewriteRule ^app/(.*) plugins/webdav/site/control/$1 [QSA,L]

# forward api requests
#RewriteRule ^api/v2/(.*)$ api/v2/index?_page_url=$1 [QSA,NC,L]

# route everything via index.php if it doesn't exist as a file
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?_page_url=$1 [QSA]
 

adam

Administrator
Staff member
Dec 5, 2009
1,972
84
48
I tested this the other day on your install and fixed it by clearing the application cache. So it may be something local to you. (browser etc). If you want me to test again, please update/add a ticket with the details and I'll look.
 

adam

Administrator
Staff member
Dec 5, 2009
1,972
84
48
I've just tested it again and see the redirect to "index", so it's happening for me aswell again. Can you share FTP access via the ticket aswell, I'll run some checks?