Error: There was a sever problem when attempting the upload

mrizwan

New Member
YetiShare User
YetiShare Supporter
Mar 15, 2021
8
0
1
I have two hosting servers right now,
One server is for website hosting (yehtishare), and 2nd is connected with remote file server,
I have too much downloads due to increase in traffic, and my 2nd server is dedicated server and downloads are too many, it have 8 cores and 16 GB ram,
Dedicated server load is 100% and core load is 40% to 50%, due to this, whenever i upload a file error (Error: There was a sever problem when attempting the upload) comes, after that file downloading runs normal.
1 GB file is uploaded in 100% but more then 1 GB file upload stops due to 100% load.
But when load is less on server then big files also upload easily, tell me a solution that how can i upload big file when load is 100%, if there is no solution then i want to attach three servers,
I will attach (yehtishare) on 1st server and i want to use 2nd server for File uploads, and when a File uploaded on 2nd server successfully it move automatically on 3rd server by that i don't have problem for file uploading,
 

Attachments

vanzi

Member
YetiShare User
YetiShare Supporter
Oct 19, 2019
48
8
8
hi, are you setup correctly your php ? other servers are direct server? to me it looks like an https problem. I've never had these problems on my servers even when they get to extreme usage thresholds. I believe there is some wrong setting in the server configuration, or the main server is too small to support requests and therefore cannot handle traffic with direct servers
 

mrizwan

New Member
YetiShare User
YetiShare Supporter
Mar 15, 2021
8
0
1
yes my others sever have direct server and My Main server is vps but vps load 0.50% and direct server load 100%, You Have fix this Problem..? @adam not reply me.
 

det3rnio

New Member
YetiShare User
Jun 12, 2020
8
0
1
Check server speed between servers and change in php.ini : max_input_time, max_execution_time to 9000+, memory_limit, post_max_size, upload_max_filesizeto 5120+ (In ngnix send_timeout)

and in mysql/my.cnf

max_connections=200
max_user_connections=50
wait_timeout=90000
interactive_timeout=500
long_query_time=5

Then try with cloudflare config turn off ssl, regenerate new ssl etc..

If this will not help that's mean your speed between servers is not fine and even don't deal with that.
Btw. where's your servers which provider, is main server the same as file server? What's server setup?