File types not uploading

hostmaster4703

New Member
YetiShare User
Jan 30, 2015
3
0
0
I'm having a problem where certain file types are not uploading.

Select a file, the upload process goes normally, no error message is shown, a file is created in /files/_tmp but the file is not shown at the end of the upload and no links are generated. All other normal files uploads work - e.g. JPG, PNG, PDF, etc. if you include good & bad file types in the same upload the links for the good files are shown, and nothing for the bad files.

This happens at least with Mac OSX .pkg and .app files, perhaps others but those are the ones I have noticed it on. It doesn't seem to due to the file extension as I can upload a JPG renamed as a PKG and it uploads OK.

This is a clean 4.4 installation & My Blocked Upload File Types & Accepted Upload File Types are both empty and haven't been changed since install.

Any assistance would be great.
 

hostmaster4703

New Member
YetiShare User
Jan 30, 2015
3
0
0
As a follow-up, this is being caused by the DocViewer plugin - I disabled that and the file uploads. Perhaps there is a unhandled exception in there were certain file type are causing the DocView plugin to crash and not process the file?
 

adam

Administrator
Staff member
Dec 5, 2009
2,034
106
63
Hi,

Have a look in the script admin, logs, to see if there's anything logged which may explain it?

Also, are these extensions set in the document viewer plugin settings?

Thanks,
Adam.
 

hostmaster4703

New Member
YetiShare User
Jan 30, 2015
3
0
0
No errors in the logs for the upload, it does show the upload (Upload request to uploadHandler.php...), and the file types are not included in the Document Types for the plugin (doc,docx,xls,xlsx,ppt,pptx,pdf,pages,ai,psd,tiff,dxf,svg,eps,ps,ttf,otf,xps).

Thanks
 

adam

Administrator
Staff member
Dec 5, 2009
2,034
106
63
Hi,

On the ticket you raised can you provide access details to your install, I'll take a look for you?

Thanks,
Adam.
 

Johnlemon

New Member
YetiShare User
Mar 3, 2017
13
0
0
Exact same issue. You have my credentials on my ticket please i don't have that plugin installed. I need the site to work.
 

Attachments

adam

Administrator
Staff member
Dec 5, 2009
2,034
106
63
For other users reference, this issue was resolved by ensuring the 'accepted upload types' in site settings was clear. It was fixed by first setting a restriction in this field, saving, then clearing and saving. Can you try the same? The field is within the admin area, site settings, upload settings.
 

black-serv6502

New Member
YetiShare User
Apr 2, 2017
19
0
0
Hello, I have exactly the same problem.
The manipulations described above did not correct the problem




For me it happens with some file the format of the file and .mp4 of other times it was .mkv.

In general after several tests it ends up passing or even compressing it in .rar, but this file does not want to pass at all ...

Do you have another solution?
thank you in advance :)
 

tomaszladniak35584

New Member
YetiShare User
YetiShare Supporter
Dec 5, 2015
48
2
0
Yes i got complains about same issue.

For me renaming file help.

Hope that Adam will find another fix soon :)
 

adam

Administrator
Staff member
Dec 5, 2009
2,034
106
63
Please see here for a relating ticket/fix:

http://forum.mfscripts.com/viewtopic.php?f=20&t=2970&p=11023#p11023