Error when try to upload files

Pain187

New Member
YetiShare User
Mar 16, 2016
13
0
0
34
Jeddah
upani.net
Hello Team,

I'm having a strange error after i update my system from nginx 1.11.1 to 1.11.2

The site start giving me this error:
Code:
Error: File received has zero size. This is likely an issue with the maximum permitted size within PHP
This is the last 3 update i did.

Jul 08 21:04:02 Updated: nginx-1.11.2-1.el6.ngx.x86_64
Jul 08 21:04:02 Updated: exim-4.84.2-3.el6.x86_64
Jul 08 21:04:03 Updated: tzdata-2016f-1.el6.noarch


Please can you help me to fix this issue :(
 

msk19994

New Member
YetiShare User
Apr 16, 2013
40
0
0
check if these sizes are less in php.ini

upload_max_filesize = 2G
post_max_size = 2G
max_execution_time = 84600
max_input_nesting_level = 84600
max_input_time = 84600

or if you are running fcgid then
modify / etc / httpd / conf.d / fcgid.conf by adding

FcgidMaxRequestLen 2147483648
or your desired size
 

Pain187

New Member
YetiShare User
Mar 16, 2016
13
0
0
34
Jeddah
upani.net
msk19994 said:
check if these sizes are less in php.ini

upload_max_filesize = 2G
post_max_size = 2G
max_execution_time = 84600
max_input_nesting_level = 84600
max_input_time = 84600

or if you are running fcgid then
modify / etc / httpd / conf.d / fcgid.conf by adding

FcgidMaxRequestLen 2147483648
or your desired size
Dear I'm using nginx with php-fpm
i have edited my php.ini file and set the same your post and restart the service still same issue.
 

Attachments

adam

Administrator
Staff member
Dec 5, 2009
2,036
106
63
Hi,

All the server tweaks you'll need to apply are here:

https://support.mfscripts.com/public/kb_view/27/

(make sure you restart the services after any changes)

Also test these:

- Ensure you don't have anything blocking uploads (like php.ini file uploads set to off)
- Test if smaller files are working
- Make sure you tmp folder isn't full

Thanks,
Adam.
 

adam

Administrator
Staff member
Dec 5, 2009
2,036
106
63
Please check ALL the information I sent including whether smaller files are working.
 

adam

Administrator
Staff member
Dec 5, 2009
2,036
106
63
Then it must be a limitation on the upload size somewhere in your server config.

All the settings we've ever found are listed on this page:

https://support.mfscripts.com/public/kb_view/27/

I'd recommend checking every one carefully aswell as ensuring you restart the services after. Also check if you have more than 1 php.ini file, i.e. you're editing the right one. Do you see the max sizes higher than 100kb in a phpinfo file? (there's a page in the script admin which will show this)

Do you have any limits on a service such as CloudFlare?

Are there any firewall limits?

It's not really a script issue as your server is blocking it somehow, but I'll do my best to help you track it down.
 

Pain187

New Member
YetiShare User
Mar 16, 2016
13
0
0
34
Jeddah
upani.net
Dear Adam,

For your information i'm using vesta panel.
and i have checked all config file they seems normal there is no issue in it and for php.ini i have 1 file only also i have checked phpinfo upload_max_filesize 10G.
and i don't use cloudflare also for fiirwall there is no limits
 

enricodias4654

Member
YetiShare User
Jan 13, 2015
411
1
16
Pain187 said:
Dear Adam,

For your information i'm using vesta panel.
and i have checked all config file they seems normal there is no issue in it and for php.ini i have 1 file only also i have checked phpinfo upload_max_filesize 10G.
and i don't use cloudflare also for fiirwall there is no limits
Check the post_max_size in the php.ini
 

fatality43835

New Member
YetiShare User
Apr 10, 2014
11
0
0
Check that the Nginx max upload size hasn't been changed to the default after the update.
Add this line to nginx.conf:
Code:
client_max_body_size 10G;
Restart Nginx.
 

rexcarnation5449

Member
YetiShare User
Oct 8, 2015
36
0
6
I have same issues like this.

But when I migrate from Vesta Panel to EasyEngine the issue is solved.

But there is any other bug.
When user has logged in and download the file, the file size is always 3MB

Do you have any suggestion Adam ?
 

msk19994

New Member
YetiShare User
Apr 16, 2013
40
0
0
I also using vestacp
and using fcgid i

modified / etc / httpd / conf.d / fcgid.conf by adding

FcgidMaxRequestLen 2147483648

and it works fine now
 

enricodias4654

Member
YetiShare User
Jan 13, 2015
411
1
16
msk19994 said:
I also using vestacp
and using fcgid i

modified / etc / httpd / conf.d / fcgid.conf by adding

FcgidMaxRequestLen 2147483648

and it works fine now
I never managed to run php scripts for too long using fcgi. I didn't take the time to search the cause, I just switched back to mod_php.