Error: Failed getting file contents

tihomir6271

New Member
YetiShare User
Hello,
I am having the following problem. When user try to download all files (zip file), after confirming to the warning that it might going to take some time, there is an error:

Found 4 files.
- Getting 20170211_003604.mp4 (108.59 MB) ... Error: Failed getting file contents (20170211_003604.mp4).
- Getting 20170211_010627.mp4 (202.42 MB) ... Error: Failed getting file contents (20170211_010627.mp4).
- Getting 20170211_010951.mp4 (353.52 MB) ... Error: Failed getting file contents (20170211_010951.mp4).
- Getting 20170211_020224.mp4 (235.36 MB) ... Error: Failed getting file contents (20170211_020224.mp4).
Saving zip file... Done!

Download Zip File (0.00 KB)

If you click on the button (just wild shot):
ERROR: Zip file no longer available, please regenerate to download again.

The log file is silent about this event and I am running out of ideas where to look for. Any tips?

Regards,
-Tiho
 

sukhman21

Member
YetiShare User
YetiShare Supporter
Jan 26, 2015
508
2
18
Are you using fileservers or just 1 server for site and storing files?
 

sukhman21

Member
YetiShare User
YetiShare Supporter
Jan 26, 2015
508
2
18
does the files actually exist on your server. check under the files/ folder and make sure the files actually exist.
If they do, verify the permissions.

I see you are using nginx. check and make sure you got the correct rules in your conf file.
 

sukhman21

Member
YetiShare User
YetiShare Supporter
Jan 26, 2015
508
2
18
Also, not sure if you use X-Accel-Redirect. but if you do, try disabling it and see if downloads work.
 

tihomir6271

New Member
YetiShare User
Files are on server (confirmed via shell and gui). I am using Apache with XSendFile for Apache enabled. I also was using CloudFlare.
XSendFile for Apache was disabled - no change
Cloudflare was disabled - no change

The problem still persist. I've checked Apache log files - no errors at all, FileShare logs - nothing there (nothing at all).

XSendFile was good hint. Sad it did't fix the problem.

Regards,
-Tiho